抱歉,您的浏览器无法访问本站
本页面需要浏览器支持(启用)JavaScript
了解详情 >

总时间限制: 1000ms 内存限制: 65536kB

描述

在一个字符串中找出元音字母 a,e,i,o,u 出现的次数。

输入

输入一行字符串(字符串中可能有空格,请用 gets (s) 方法把一行字符串输入到字符数组 s 中),字符串长度小于 80 个字符。

输出

输出一行,依次输出 a,e,i,o,u 在输入字符串中出现的次数,整数之间用空格分隔。

样例输入

1
If so, you already have a Google Account. You can sign in on the right.

样例输出

1
5 4 3 7 3

提示

注意,只统计小写元音字母 a,e,i,o,u 出现的次数。

来源

计算概论 05

思路

遍历字符串,统计元音字母的个数。

这里可以考虑使用一个哈希表来存储元音字母的个数。

Code

C++ STL

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <bits/stdc++.h>
using namespace std;

int main() {
string str;
map<char, int> mp;
getline(cin, str);
for (long long unsigned int i = 0; i < str.size(); i++) {
if (str[i] == 'a' || str[i] == 'e' || str[i] == 'i' || str[i] == 'o' || str[i] == 'u') mp[str[i]]++;
}
for(auto i: mp) {
cout << i.second << " ";
}
}