总时间限制: 1000ms 内存限制: 65536kB
描述
有三个字符串 S,S1,S2,其中,S 长度不超过 300,S1 和 S2 的长度不超过 10。想检测 S1 和 S2 是否同时在 S 中出现,且 S1 位于 S2 的左边,并在 S 中互不交叉(即,S1 的右边界点在 S2 的左边界点的左侧)。计算满足上述条件的最大跨距(即,最大间隔距离:最右边的 S2 的起始点与最左边的 S1 的终止点之间的字符数目)。如果没有满足条件的 S1,S2 存在,则输出 - 1。
例如,S = “abcd123ab888efghij45ef67kl”, S1=“ab”, S2=“ef”,其中,S1 在 S 中出现了 2 次,S2 也在 S 中出现了 2 次,最大跨距为:18。
输入
三个串:S, S1, S2,其间以逗号间隔(注意,S, S1, S2 中均不含逗号和空格);
输出
S1 和 S2 在 S 最大跨距;若在 S 中没有满足条件的 S1 和 S2,则输出 - 1。
样例输入
1
| abcd123ab888efghij45ef67kl,ab,ef
|
样例输出
思路
- 就是使用
string
的 find
和 rfind
方法,分别找到 S1
和 S2
在 S
中的位置,然后计算最大跨距。
- 如果
S1
和 S2
中有一个找不到,则输出 -1
。
注意
string
中的 length
方法和 size
方返回的是 unsigned int
类型,所以在比较时要注意类型转换,如果直接计算会出现错误。(这还是我的朋友告诉我的,那时我还不知道这个问题)
Code
C++ STL
第一种写法
1 2 3 4 5 6 7 8 9 10 11 12 13 14
| #include <bits/stdc++.h> using namespace std;
int main() { string S, S1, S2; getline(cin, S, ','); getline(cin, S1, ','); getline(cin, S2); int a = S.find(S1), b = S.rfind(S2), c = S1.length(); if(a == -1 || b == -1 || a > b) cout << "-1"; else { cout << b - (a+c); } }
|
第二种写法
1 2 3 4 5 6 7 8 9 10 11 12 13 14
| #include <bits/stdc++.h> using namespace std;
int main() { string S, S1, S2; getline(cin, S, ','); getline(cin, S1, ','); getline(cin, S2); int a = S.find(S1), b = S.rfind(S2), c = S1.length(); if(a == -1 || b == -1 || b - (a+c) < 0) cout << "-1"; else { cout << b - (a+c); } }
|
第三种写法
1 2 3 4 5 6 7 8 9 10 11 12 13 14
| #include <bits/stdc++.h> using namespace std;
int main() { string S, S1, S2; getline(cin, S, ','); getline(cin, S1, ','); getline(cin, S2); int a = S.find(S1), b = S.rfind(S2); if(a == -1 || b == -1 || b - (a+(int)S1.length() < 0)) cout << "-1"; else { cout << b - (a+(int)S1.length()); } }
|
第四种写法
1 2 3 4 5 6 7 8 9 10 11 12 13 14
| #include <bits/stdc++.h> using namespace std;
int main() { string S, S1, S2; getline(cin, S, ','); getline(cin, S1, ','); getline(cin, S2); int a = S.find(S1), b = S.rfind(S2), c = S1.length(); if(a == -1 || b == -1 || a > b) cout << "-1"; else { cout << b - (a+(int)S1.length()); } }
|